2011年08月08日

1.6/2.0以上両対応のコンタクトリストへのアクセス

そんな訳で新たに作ったアプリを公開直前でIS01(OS1.6)で動作しないことに気づき、急遽延期した訳ですが、今回のアプリはコンタクトリストを使うので、OS2.0以降でアクセス方法が変わっていることが引っかかっていると思われました。
1.6のHT-03Aで動いていたのは不思議と言えば不思議なのかも知れませんが、なにせOS1.6のエミュレーターがまともに起動しないので、純粋な(?)1.6での確認が取れません。
いったんはバイナリを分けようと思ったのですが、AndroidマーケットのMultiple APK Supportではできるだけバイナリをひとつにしろとか書かれているようです。
仕方なく再度ググってみたところ、2chと以下のサイトにリフレクションを使わないとダメだという記載を見つけました。

続きを読む
posted by 白虹 at 23:58| Comment(0) | TrackBack(0) | Android開発